Neues Thema starten

Shopware Addon

Moin zusammen,


frickel gerade mit dem Shopware Addon rum, aber irgendwie fehlen mir da doch noch eine Menge Sachen um es auch Produktiv nutzen zu können, vielleicht bin ich ja auch zu doof, aber ich kann bei dem Step Add Products weder die Artikel Freitextfelder die ja im standard bei Shopware attr1 - attr20 vorhanden sind, setzen, noch die Kategorie oder auch Bilder. 

Ich habe aber auch keinen anderen Step gefunden der mir die Bilder und Kategorien anlegt, ich kann dann zwar Artikel anlegen, habe aber weder Bilder noch Kategorie, irgendeiner eine Idee wie das umzusetzen ist?

Gruß

Michael


Hallo Michael,


wir haben den Step noch ein wenig erweitert. Du kannst jetzt: 

  • die 20 Standard Artikel - Freitextfelder setzen (Zielspalte Attribute1 - Attribute20 )
  • Bilder hinzufügen (Zielspalte Images). Mehrere Bild Urls können in dieser Spalte Komma - separiert angeben werden.
  • Kategorien setzen (Zielspalte CategoryPaths). In dieser Spalte muss der gesamte Kategoriepfad Pipe (|) getrennt angeben werden, z.B: Deutsch|Test123 . Mehrere Kategoriepfade werden durch Semikolon getrennt, z.B: Deutsch|Test123;Englisch|Test321

Die neuen Zielspalten kannst du in der Mapping Ansicht über "Spalten" -> "Zielspalte hinzufügen" deinem bisherigen Mapping hinzufügen. 


Falls du noch Fragen oder Probleme hast kannst du dich gerne nochmal bei uns melden.


Viele Grüße

Ihr Synesty Support



Jungs, das ist der Hammer! Das ging ja sowas von schnell. Das werde ich gleich testen. Vielen vielen Dank. 

eins hätte ich noch, der Pseudo Price (UVP) und Metatitle lässt sich noch nicht über Synesty abgleichen, könntet ihr das vielleicht noch mit einbauen, falls mir noch mehr auffällt was noch fehlt, darf ich das dann hier mit rein setzen? Vielleicht ja für euch auch ganz gut, je mehr abgeglichen werden kann umso besser für zukünftige Kunden ;-)


Hallo Michael, 


vielen Dank für den Hinweis. Wir werden die beiden Felder dem Step noch hinzufügen. Den PseudoPrice könntest du jetzt schon über den ShopwareSetPrice Step setzen. Falls dir noch weitere Felder fehlen kannst du es gerne hier rein schreiben.


Viele Grüße

Ihr Synesty Support


1 Person gefällt dies

Soweit fast so gut, Leider lassen sich wohl die Bilder nicht importieren, es kommt immer folgende Fehlermeldung wenn ich den Flow ausführe:


2016-05-10 14:24:15 [STEP #3] ShopwareAddProducts
WARNING:Could not create article with number 118165. Internal Server Error:Internal Shopware API error: Internal Server Error Errormesage: Could not open http://pixcluster2.freshworx.de/pix736794/2015-11/P1240281.JPG for reading


Das Bild ist aber definitiv vorhanden und kann auch abgerufen werden, es ist das erste Bild, weiter geht es ja nicht da er ja den import dann abbricht, eine idee woran es liegt?



Nachtrag: Habe mal versucht das Bild auf dem gleichen Server abzulegen auf dem auch der Shop läuf, bringt nix aber eine neue Fehlermeldung:


2016-05-10 14:36:12 [STEP #3] ShopwareAddProducts
WARNING:Could not create article with number 118165. Internal Server Error:Internal Shopware API error: Internal Server Error Errormesage: Unsupported schema ''.

LastStock fehlt auch noch, damit kann man den Abverkauf steuern


ok, das mit den Bilder habe ich jetzt hinbekommen, Fehlermeldungen sind weg, es lag daran das ich mit if die einzelnen Bilder aus mehreren Spalten zusammengefügt habe um die mit Komma zu trennen, so wie die Shopware API das erwartet. Zur besseren Übersicht der Schleife habe ich mit Umbrüchen gearbeitet. Problem war das dann zwischen den Bildern zwar ein Komma war, aber auch ein Leerzeichen, nachdem ich sämtliche Zeilenumbrüche gelöscht habe, war das Problem erledigt und der Artikel wurde mit sämtlichen Bilder importiert. Das hat mich allerdings einige Flows gekostet bis ich das rausbekommen habe :-)


Das einzige was nicht funktioniert ist die Markierung für Versandkostenfrei, dort wird entweder ein true oder false erwartet. Ich übergebe auch ein true, aber es wird nicht als Versandkostenfrei markiert. Könnt ihr euch das bitte nochmal ansehen? Es kommt auch keine Warnung oder Fehlermeldung


Und wie geschrieben, LastStock fehlt noch. Damit wäre dann zumindest für Artikel ohne Varianten erstmal alles vorhanden. 

Hallo Michael,


LastStock bauen wir auch noch ein. 


Die 1. Bildurl (http://pixcluster2.freshworx.de/pix736794/2015-11/P1240281.JPG) habe ich erfolgreich in 2 Testsysteme von uns importiert (V. 4.2.1 und 5.0.0). Der Import ist noch recht anfällig was Leerzeichen und Zeilenumbrüche angeht. Kannst du mal Testen ob der Import mit nur der URL http://pixcluster2.freshworx.de/pix736794/2015-11/P1240281.JPG im Wert - Feld  funktioniert. Falls ja, dann sind wahrscheinlich noch irgendwo Zeilenumbrüche oder Leerzeichen im Feld vorhanden.


Viele Grüße

Ihr Synesty Support

Es lag wie geschrieben in der Tat an Leerzeichen. Was leider absolut nicht funktioniert ist das setzen von der Versandkostenfrei Markeirung (ShippingFree) egal ob true oder false, es wird nichts gesetzt, da "dürft" ihr gerne noch mal reinschauen, ansonsten hat der Import der Bilder jetzt geklappt. Werde weiter testen und berichten ;-)


Läuft mittlerweile super, ein Problem gibt es aber irgendwie noch. Die Artikel erscheinen trotz aller Daten nicht im Shop. Wenn ich dann einen Artikel im Shopware Backend öffne, nichts ändere und einmal abspeichere geht es. Gibt es dazu irgendeine Idee? Es wird am Artikel nichts geändert, nur abgespeichert, danach geht es. Habe es mit vielen Artikeln getestet, keiner lässt sich im Frontend aufrufen, erst nach dem speichern.

Eventuell könnte euch das bei dem Problem helfen: http://forum.shopware.com/discussion/29687/artikel-sichtbarkeit-nach-api-import


Hallo Michael, 


vielen Dank für den Hinweis. Ich konnte das Problem in unserem Testshop nachstellen. Die Ursache scheint tatsächlich zu sein, dass active zwar korrekt am Artikel, aber nicht an den Artikeldetails gesetzt wird. Wir haben das jetzt gefixt. Die Änderung wird dir dann wahrscheinlich ab Anfang/Mitte nächster Woche auf unseren Live - System zur Verfügung stehen.


Viele Grüße

Ihr Synesty Support

Anmelden um einen Kommentar zu veröffentlichen