Neues Thema starten
In Arbeit

Wunschliste :-)

 Hallo Synesty-Team,


ich habe es an zwei Stellen immer wieder mit aus meiner Sicht unschönem Verhalten bei der Flowbearbeitung zu tun.

Die erste: Ich bin im "Step-Baum", wo ich links meine Steps sehe, von denen einer aktiviert ist, und rechts sehe ich dessen Details. Ich möchte nun einen Step direkt darunter einfügen, und er soll automatisch mit diesem gerade aktiven verknüpft werden. Leider klappt das nicht immer: Manchmal wird mir der neue Step oberhalb des aktiven eingefügt, manchmal zwei weiter unten, und manchmal korrekt direkt darunter. Könntet ihr das möglicherweise vereinheitlichen?

Die zweite: Ich benenne meine Steps meistens irgendwie logisch, um mich bei komplexeren Strukturen zurechtzufinden. Dazu numeriere ich sie teilweise, z.B. SpreadsheetMapper|nVnA_01, SpreadsheetMapper|nVnA_02 usw. Im alten GUI konnte ich z.B. im letztgenannten (aktivierten) Step per Copy/Paste in den Namen des Erstgenannten gehen und mir diesen Namen in den gerade aktiven Step reinkopieren, anschließend dann nur noch 1 gegen 2 austauschen (das ist nur ein Beispiel, teilweise sind das längere Namen). In dem neuen "Baum-GUI" kann ich das leider nicht mehr machen. Ich muß immer erst in den gerade nicht aktiven Step wechseln, um mir seine Benennung holen zu können, und anschließend in den, den ich gerade bearbeite, um das Paste durchzuführen. Das ist bei längeren Flows echt nervig.

Ansonsten auch mal ein Lob: Super finde ich die Möglichkeit, im "Alle Steps bearbeiten" durch einfachen Klick einen Step an die erste Stelle zu verschieben - sehr hilfreich!


Ich hoffe, ihr könnt hier etwas Kosmetik betreiben ;-)


Danke und Gruß, Micha


Es wurde ein Fix eingespielt, der das Reihenfolge-Problem beheben sollte. 

Wir sind dran. Du kannst dir die Flow-Exporte erstmal sparen. 

Ups, hatte euren Post gar nicht zu Ende gelesen. Ja okay, mal sehen, wann ich Zeit dafür finde

Ich weiß, es brach ab, weil es plötzlich funktionierte. Wieder und wieder, ich dachte schon, ihr hättet da was ganz frisch ausgerollt. Irgendwann habe ich dann aufgegeben, einen solchen Zeitpunkt zu erwischen, und schwupps, hat er wieder einen Step völlig falsch placiert, diesmal sogar zwei Stellen zu hoch.

Meines Erachtens passiert das völlig willkührlich, sowohl in der Arbeit in alten wie auch in neuen Flows - und auch in allen Browsern, aber das habe ich nicht wirklich getrackt, ist nur ein Gefühl. Da ich in meinem Produktivaccount meistens mit Opera, und in meinem Zertifizierungsaccount in FF oder Chrome arbeite, habe ich da ja einige im Einsatz.


Was kann ich denn tun, um euch eine bessere Grundlage zur Recherche zu liefern?


... und dann? ;) Vermutlich hat es nicht geklappt, aber dein Beitrag wirkt unvollständig. 


Problem ist, dass wir das nicht reproduzieren können. Bei uns klappt das einfügen von Steps zwischen drin. 

Daher die Frage:

Kannst du das in einem neuen Test-Flow machen und mal nach jedem Schritt den du machst, einen Flow-Export machen inkl. dem letzten Schritt, wo es dann falsch wird? 

Lass uns diese ganzen Exporte mal zukommen (per Ticket mit Referenz auf diesen Forumsbeitrag). Damit haben wir evtl. eine Chance das zu reproduzieren.  


Frage: passiert das bei neuen Flows oder bei alten Flows (alte = Flows die schon seit einigen Monaten existieren)?

Hallo, normalerweise kenne ich es von euch ja, daß Sachen in Windeseile umgesetzt werden. Ich denke, daß dieser Thread irgendwie hinter die Heizung gefallen sein muß...Also, es ist wirklich total nervig, daß beim gewünschten Einfügen eines Steps in der Baumansicht ständig folgendes passiert:


1. Ausgangssituation: Ich möchte einen Step unterhalb des gerade markierten einfügen:

image


2. Ich fahre bei diesem Step mit der Maus drüber und klicke auf "Step hinzufügen":

image


3. Ich wähle den neuen Step aus


Hallo,

Sorry fürs vorzeitige schließen. Das mit dem "Einfügen darunter" schauen wir uns noch mal an.  Beim nächsten mal bitte einzelne Themen im Forum eröffnen - das hilft uns besser den Überblick zu behalten ;)

Hallo, das Thema wurde gerade als implementiert gemeldet. Ich bin aktuell am Arbeiten in den Flows und stelle aber immer wieder fest, daß Steps, die ich unterhalb eines anderen mit Klick auf den Link "+ Step hinzufügen" hinzufügen möchte, manchmal oberhalb des gerade aktiven eingefügt werden statt unterhalb. Dann muß man ihn immer wieder manuell auf die korrekte Stelle ziehen und die Verlinkung korrigieren. Habt ihr das auf dem Schirm?

Gruß Micha

 

Hallo Micha,


dank dir für die konstruktive Kritik und das Lob :)


Zu 1.:

Das schauen wir uns an, ist natürlich nicht im Sinne des Erfinders das der Step nicht immer direkt dahinter eingefügt wird.


Zu 2.:

Ich bin mir nicht sicher, ob ich das richtig verstanden habe:
Ist dein Problem das du beim versuch den Stepnamen zu kopieren (markieren des Textes mit der Maus) ungewollt direkt in den Step wechselst?

Bis dahin erstmal zwei mögliche Workarounds:

a) Du benennst die Steps in der Flowübersicht um:


b) Du benennst die Steps in der "Alle Steps bearbeiten" Ansicht um



Viele Grüße,

Benjamin




1 Person gefällt dies
Anmelden um einen Kommentar zu veröffentlichen