Neues Thema starten
Beantwortet

BIlder werden nicht nach Shopware übertragen

Hallo, ich versuche Bilder aus einer CSV in Shopware zu aktualisieren. Leider bekomme ich immer folgende Fehlermeldung:
Letzte Meldung: Could not update article number: 1000004526. Internal Server Error:Internal Shopware API error: Internal Server Error
Error message: Could not open http://pixcluster2.freshworx.de/pix736794/2015-11/P1240281.JPG for reading Skipping row...


Die Bilderpfade haben weder Leerzeichen, Absätze oder sonstiges. Selbst als Wert angelegte Pfade:  zB. http://pixcluster2.freshworx.de/pix736794/2015-11/P1240281.JPG

kommen auf diese Fehlermeldung?!


Beste Antwort

Der Fehler lag an meinem Hoster!


Hier ein kleiner Auszug aus dem Shopware Forum:

"Das Problem ist eine Konfiguration des Hosters, der verhindert, dass Skripts URLs öffnen; und genau das ist, was man beim Bilderimport macht.


Um zu prüfen, ob das auch bei dir das Problem ist, schaue im Shopware-Backend unter Einstellungen->Systeminfo nach, und zwar bei Server-Einstellungen.

Dies zeigt dir dann deine aktuellen Einstellungen deines Webservers.

Jetzt suche den Parameter "allow_url_fopen" und schau, ob das ein grünes Häkchen hat.

Wenn nicht, ist das dein Problem: dieser Wert muss aktiv sein, sonst bekommst du genau deine Fehlermeldung."


Das hat das Problem gelöst!


Der Fehler kommt von Shopware. 


Eine Sache die auffällt: Wenn man deine (http) URL öffnet, zeigt der Browser diese mit https an. 

Das sieht nach einer Weiterleitung aus, die Shopware evtl. nicht kann.

Versuch mal die Bild-URL direkt als HTTPs zu schicken. Vielleicht hilft das.

leider nein. habe nun mit: https://pixcluster2.freshworx.de/pix736794/2015-11/P1240281.JPG den Wert im Mapping gefüllt und wieder die gleiche Fehlermeldung


die Meldung klingt, als kann Shopware die Bild-URL nicht laden. 

Mehr können wir hier leider auch nicht sagen.


Kannst du testweise mal eine andere Bild-URL nehmen, die auf einem komplett anderen Server liegt? (oder mal weglassen, um sicherzugehen, dass es das Bild ist). 

Vielleicht ist es eine Firewall Problematik. Oder das Bild ist zu groß und die Shopware-Installation stößt an Speichergrenzen (PHP). 

Antwort

Der Fehler lag an meinem Hoster!


Hier ein kleiner Auszug aus dem Shopware Forum:

"Das Problem ist eine Konfiguration des Hosters, der verhindert, dass Skripts URLs öffnen; und genau das ist, was man beim Bilderimport macht.


Um zu prüfen, ob das auch bei dir das Problem ist, schaue im Shopware-Backend unter Einstellungen->Systeminfo nach, und zwar bei Server-Einstellungen.

Dies zeigt dir dann deine aktuellen Einstellungen deines Webservers.

Jetzt suche den Parameter "allow_url_fopen" und schau, ob das ein grünes Häkchen hat.

Wenn nicht, ist das dein Problem: dieser Wert muss aktiv sein, sonst bekommst du genau deine Fehlermeldung."


Das hat das Problem gelöst!

Viele Dank für die Rückmeldung. Wir haben einen Hinweis dazu mit im Handbuch aufgenommen.

Anmelden um einen Kommentar zu veröffentlichen