Neues Thema starten

FTPUpload mit uploadWithTempName und SFTP

Hallo Synesty,


mit ist aufgefallen, dass ein Prefix, welcher beim Upload von Dateien via SFTP versehen worden, dort nicht wieder entfernt werden. Bei einer FTP Verbindung funktioniert der Schritt allerdings.


Festgestellt im Flow Galaxus_Feed_Cronjob (wo es jedoch schon wieder rückgängig gemacht wurde).


Könnten ihr das bitte prüfen?


Vielen Dank!


Christian Sobek


Hallo Christian, 


danke für deine Rückmeldung. Bisher haben wir das Problem bei keinem anderen Kunden festgestellt. Wir sind aber trotzdem stark daran interessiert die Ursache für das Problem zu finden. Wir haben für den SFTP Upload unser internes Logging noch ein wenig verbessert. Wir würden uns sehr freuen wenn du den Flow (mit Prefix Upload) nochmal ausführen könntest und uns die RunID schickst. 


Viele Grüße

Torsten


1 Person gefällt dies

Hallo Torsten,


das Problem tritt nicht nur auf, sofern die Art von Dateien schon existieren. Auch bei leerem Zielverzeichnis.

An Berechtigungen liegt es meiner Meinung nach nicht, da mit gleichem User per FTP die Files im Anschluss geändert werden können (rename).


Sofern es nur bei mir auftritt, würde ich es jetzt mal so stehen lassen. Ich arbeite ohne dieses Feature, wollte es jedoch gemeldet habe.


Beste Grüße,


Christian

Hallo Torsten,


schön, dass ihr so hartnäckig seid.


Anbei die Run ID:

RunID: 9f973306-d15d-11e8-9e13-901b0ea49fee


Viele Grüße,


Christian

Vielen Dank! Immerhin kommt jetzt schon eine Warnung im Flow Eventlog, dass das Umbenennen nicht funktioniert hat. Ich schau mir unseren Log morgen gleich an. 

Hallo Christian,


es sollte jetzt funktionieren. Es lag daran, dass die Zieldatei schon existiert hat. Beim Versuch die temporäre Datei umzubenennen haben wir ein Fehler erhalten. Wir haben es jetzt so gelöst, dass im Fehlerfall die vorhandene Datei entfernt wird. 


Viele Grüße

Torsten 

Hallo Christian, 


wir haben versucht das Problem zu reproduzieren. Bei unserem Test SFTP Server wird der Prefix nach dem Upload wieder korrekt entfernt.

Waren die Dateien (ohne Prefix) auf dem Server / im Verzeichnis schon vorhanden ?  Kannst du diese evtl. vorher löschen und den FTPUpload mit Prefix nochmal ausführen. Wir vermuten das es bei dir vielleicht ein Problem Berechtigungen gibt.


Vielen Dank

Torsten



Anmelden um einen Kommentar zu veröffentlichen