Neues Thema starten

ShopwareUpdateProducts ext. 5.2 - Could not create temp directory

Hallo,


ich habe bei dem ShopwareUpdateProducts ext. 5.2 Step das Problem, dass ab und an folgende Fehlermeldung auftritt:


WARNINGWARNING:Could not update article number: 9506. (Root Causes: InternalServerErrorException: Internal Server Error:Internal Shopware API error: Internal Server Error
Error message: Could not create temp directory "/tmp/PqG57O") Skipping row...


Das merkwürdige an der Fehlermeldung:

Als ich die Spalte ArticleId noch im Step hatte trat dieser Fehler bei fast jedem Produkt auf. Nach dem Löschen dieser Spalte tritt der Fehler nicht mehr allzu oft auf, allerdings wäre es natürlich ideal wenn der Fehler gar nicht mehr auftritt.


Ich hatte zuerst die Vermutung, dass es an einer Shopware Einstellung liegen könnte, nachdem es aber ohne die Spalte ArticleId nun zuverlässiger läuft dachte ich, ich frage mal hier nach.


Viele Grüße

Florian


Ich muss meine Aussage revidieren, der Fehler tritt nun wieder vermehrt auf, eventuell wieder ein Problem, dass nur auf manchen Workern auftaucht?


Mir ist außerdem aufgefallen, dass wenn das Update mal funktioniert, die Kategorien nicht geupdatet werden. Der Mode ist hier auf Replace Categories, die Kategorie in Shopware ist bisher noch nicht hinterlegt, wird aber auch durch ein Update nicht hinzugefügt.


Der Kategoriestring ist wie folgt aufgebaut:

Deutsch|Accessoires|Geldbörsen;Deutsch|Marken|BAGAN


Zielsystem ist übrigends ein Shopware 5.5.4

Hallo Florian, 


die Fehlermeldung Could not create temp directory "/tmp/PqG57O" kommt von Shopware (Bild-)Medienimport und hängt nicht mit unseren Workern zusammen. Die Bilder werden von Shopware zunächst in ein temporäres Verzeichnis importiert (/tmp/...). Falls der Bildimport generell nicht funktioniert: Kannst du mal die Berechtigungen für dieses Verzeichnis prüfen ? Falls es nur bei einigen Artikel zu dem Fehler kommt, wäre es super wenn du uns den Inhalt der Spalte Images zur Verfügung stellen könntest.


Die Replace Categories Option habe ich gerade nochmal mit deinem Kategoriestring getestet und es hat funktioniert.  Alle zugewiesen Kategorien wurden ersetzt. 

Wenn die Kategorien noch nicht vorhanden sind, würde ich dir empfehlen sie vorab über den ShopwareAddCategories anzulegen, da es ansonsten zu einem Problem mit dem Pfad der Kateorie kommen kann, https://synesty.freshdesk.com/a/forums/topics/11000021160


Eventuell ist bei deinem Produkt Update doch noch ein anderer Fehler aufgetreten ? Vielleicht kannst du das Update auf den Artikel einschränken, den Debug Modus im Flow aktivieren und uns den Log schicken.





Viele Grüße

Torsten



Hallo Torsten,


vielen Dank für die Rückmeldung.

Habt ihr das ganze mit dem UpdateProducts ext. 5.2 Step getestet?

Ich habe den DebugMode mal aktiviert (hier besteht übrigends noch ein Bug, dass man den Download im EventLog auf Safari nicht sieht).


Im Log sehe ich von 24 Spalten, die das Spreadsheet hat nur 11 Spalten, die in der Update JSON stehen. U.a. fehlt auch die Kategorie.

Bei dem Artikel besteht das Warning mit dem tmp Ordner nicht, der Flow läuft für den Artikel sauber durch.




2019-01-17 19:00:08,631 1 * Client in-bound response

1 < 200

1 < Transfer-Encoding: chunked

1 < Keep-Alive: timeout=5, max=100

1 < X-Frame-Options: SAMEORIGIN

1 < Cache-Control: no-cache, private

1 < Server: Apache

1 < Connection: Upgrade, Keep-Alive

1 < Vary: Accept-Encoding

1 < Upgrade: h2,h2c

1 < Date: Thu, 17 Jan 2019 18:00:08 GMT

1 < Content-Type: application/json

1 < 

{"data":{"version":"5.5.4","revision":"201812030839"},"success":true}


2019-01-17 19:00:08,727 2 * Client out-bound request

2 > PUT http://www.XXX.eu/api/variants/019947-194?useNumberAsId=1

2 > Content-Type: application/json

2 > Accept: application/json

{"active":"1","supplierNumber":"","inStock":19,"weight":0.045,"ean":"4260543037352","attribute":{"bullet1":"Höhe 15 cm x Breite 11 cm x Tiefe 1 cm","bullet4":"2 Steckfächer für SIM Karten","bullet5":"schützt Ihren Reisepass vor Abnutzungen","bullet2":"100 % echtes Leder","bullet3":"flache, elastische Form; passt in jedes Handgepäck"},"number":"019947-194"}


2019-01-17 19:00:09,428 2 * Client in-bound response

2 < 200

2 < Transfer-Encoding: chunked

2 < Keep-Alive: timeout=5, max=100

2 < X-Frame-Options: SAMEORIGIN

2 < Cache-Control: no-cache, private

2 < Server: Apache

2 < Connection: Upgrade, Keep-Alive

2 < Vary: Accept-Encoding

2 < Upgrade: h2,h2c

2 < Date: Thu, 17 Jan 2019 18:00:09 GMT

2 < Content-Type: application/json

2 < 

{"success":true,"data":{"id":1715,"location":"http:\/\/www.XXX.eu\/api\/variants\/1715"}}


2019-01-17 19:00:09,655 Finish Flow Run b65f19e0-1a81-11e9-ac0f-901b0ea49fee







Hallo Torsten,


ich möchte wirklich nicht drängeln, allerdings läuft uns hier etwas die Zeit davon, da dass ganze bis zum 31.01 live gehen muss. Gibt es hier schon Neuigkeiten?

Hi Florian, 


sorry für die späte Antwort, aber ich hab die Ursache für das Problem bisher einfach nicht gefunden.  Mir ist aber gerade im Log noch aufgefallen, dass dein Update auf eine Variante geht (api/variants/...). Bei Varianten Updates kann leider keine Kategorie gesetzt werden.  Die Kategorien können nur am Artikel (wenn ArticleNumber = MainArticleNumber) gesetzt werden. Der Step ist in der Hinsicht leider etwas verwirrend, weil sowohl Artikel und Variantendaten aktualisiert werden können, bei Varianten aber nicht alle Zielspalten möglich sind. Im Prinzip können nur die Felder aus den Details der Variante (siehe Screenshot) gesetzt werden. Alles andere muss am Artikel (Hauptvariante) gesetzt werden.




Die andere Fehlermeldung Could not create temp directory "/tmp/PqG57O" kommt wie gesagt vom Shopware (Bild-)Medienimport . Wir konnten den Fehlermeldung bisher nur reproduzieren, wenn die Bild Url falsch ist (z.B. nur ".jpg" ). Vielleicht findest du noch genauere Infos im System Log von Shopware.  Falls du nichts findest kannst du mir auch gerne die Bild Urls schicken, die nicht importiert werden können.

  

Ich hoffe das hilft dir erstmal weiter.


VG Torsten

Hallo Torsten,


vielen Dank für die wie immer super Hilfe.

Der Tipp mit der API Route /variants/ war schonmal hilfreich!

Nur ist das Produkt mit dem ich es getestet habe die Hauptvariante, also hätte es eigentlich funktionieren sollen. Ich habe die Spalte ArticleID auch wieder in das Spreadsheet aufgenommen, dann wurde es erst richtig erkannt und ich habe durch den Debug Modus den korrekten Call mit Bildern, Kategorien und allem drum und dran erhalten. Evtl. hier noch ein Bug im Step ?


Ich habe auch jedes Bild im Call getestet, die Links sind alle korrekt und funktional, ich erhalte aber leider immernoch die bekannte Fehlermeldung "Could not create temp directory /tmp/xxxx"

Das gute für euch: Ich habe den Call mal mit einem externen Tool getestet und erhalte dort auch die selbe Fehlermeldung. Wenn ich die Bilder rausnehme, wird alles korrekt (auch Kategorien) importiert.

Synesty kann also hier definitiv als mögliche Fehlerquelle ausgeschlossen werden.

Der Shopware Log hat leider auch nicht groß weiterhelfen können.


Da der Fehler nicht bei euch liegt ist die Frage inwiefern ihr euch mit dem Problem weiter beschäftigen könnt ? Kann ich euch mal euren Log und den von Shopware zuschicken ? Am besten per Mail (wohin)?


Parallel wende ich mich dann jetzt auch einmal an Shopware und halte euch natürlich auf den laufenden.


Vielen Dank.


Hallo Florian, 


du kannst uns gerne den Shopware Log schicken (per Ticket). Eventuell finden wir ja was.  Wir hatten diese Fehlermeldung auch schon bei einem anderen Kunden und konnten bisher leider nicht herausfinden woran es liegt. Falls du etwas heraus findest wäre es super wenn du hier kurz schreibst. 


Der UpdateProducts Step (ohne gefüllte ID Spalte) macht nur ein Artikel Update, wenn die Spalte "MainArticleNumber" leer oder "MainArticleNumber" gleich "ArticleNumber" ist.  Ich vermute mal, dass die MainArticleNumber bei dir gefüllt aber nicht gleich der ArticleNumber war.


Viele Grüße

Torsten



Hallo Torsten,


wir haben das Problem lösen können, indem wir den Inhalt des /tmp Ordners gelöscht haben hier haben sich rund 43GB Daten angesammelt. Nachdem Löschen der Inhalte hat alles wieder super funktioniert.

Ein Cronjob löscht hier jetzt regelmäßig alles raus.


Danke nochmal für den Support.

Hi Florian, 


danke für die Rückmeldung! 


Viele Grüße

Torsten

Anmelden um einen Kommentar zu veröffentlichen